2014.06.24 14:57

yum 실행 오류.

openssl 재설치 하려다 엉뚱한 패키지들까지 삭제 되는바람에 yum이 실행 오류를 일으키고 있음.

Traceback (most recent call last):
  File "/usr/bin/yum", line 4, in ?
    import yum
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 51, in ?
    import config
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 27, in ?
    from parser import ConfigPreProcessor
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 3, in ?
    import urlgrabber
  File "/usr/lib/python2.4/site-packages/urlgrabber/__init__.py", line 53, in ?
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 412, in ?
    import keepalive
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 339, in ?
    class HTTPSHandler(KeepAliveHandler, urllib2.HTTPSHandler):
AttributeError: 'module' object has no attribute 'HTTPSHandler'

 

 

# rpm -Va python\* yum\*

 

 

Unsatisfied dependencies for python-libs-2.4.3-46.el5.x86_64: libcrypto.so.6()(64bit), libssl.so.6()(64bit)
.M......    /usr/bin/python
.M......    /usr/bin/python2.4
S.5....T  c /etc/yum/pluginconf.d/fastestmirror.conf

이 후에도 실행이 정상적으로 안 되면

#]rpm -Uvh --force --nodeps /var/cache/yum/*/packages/*.rpm

이렇게 캐쉬 업데이트

Trackback 0 Comment 0