2018.11.01 19:17

php에 예전 그누보드 스킨이나 빌더 설치 할 때 여는 태그 <? 지원 설정

그누보드 예전 스킨이나 제로보드4 버전 등으로 제작 된 사이트를 구동하고 있는 서버를 업그레이드 할 경우 자주 접하게 되는 오류가 php 스크립트를 여는 태그인 <?를 지원하지 않는 것이다.

편의상 <?로 스크립트를 시작하는 경우가 많은데 php 상위 버전에서는 <?php 사용을 권고하고 있다. 그래도 예전에 만들었던 스킨을 계속 사용하고자 할 때 서버에서 php.ini 설정으로 <?php와 <?를 모두 사용 할 수 있다.


#] php -ini | grep php.ini

php.ini 파일이 위치한 곳을 찾는다.


#] vi php.ini


short_open_tag = On

“<?php” 와 “<?” 둘 다 사용 할 수 있다.

        

Trackback 0 Comment 0